I locked myself out of the site :)

Bonsai Nut

Nuttier than your average Nut
Messages
9,199
Reaction score
16,839
Location
Charlotte area, North Carolina
USDA Zone
7B
Well I had an interesting moment today when I inadvertently locked myself out of the site - including all access to the server :) I always enjoy these problems because I learn something along the way... and it may lead to solving some of the uncommon problems that people occasionally have with the site.

I was in the middle of posting a response to a post, and got tripped up in what I was posting, so I pasted my response into the clipboard and hit the browser refresh button (F5) a few times. The web page locked up (!) so I closed my browser window and tried to reload the site again - to no avail. So I tried to access my admin account, and couldn't. Then I tried to access the client account on the server, and couldn't. Suffice it to say I was completely unable to interact with the site - even though my hosting account showed the server was up, and I was having no trouble accessing other Internet sites.

Turns out that I had spammed my way into a temporary firewall block of my IP by pinging the server too many times in too short a span of time :) Kinda funny when you think about it. It is probably a pretty rare occurrence since this is the first time it has happened to me - and I am on the site a lot and am constantly refreshing the site and reloading things. If it happens again, I'll have to tweak the firewall settings. For a couple of minutes I thought the site was being hit with a denial of service attack by Russian bots because I could see all the firewall messages - and then I realized the IP it was blocking was mine :)
 

Bonsai Nut

Nuttier than your average Nut
Messages
9,199
Reaction score
16,839
Location
Charlotte area, North Carolina
USDA Zone
7B
So how did you get back in?

Well I could always contact my server host and they would get me back in... but while I was in the process of figuring out the problem, the firewall block expired. Worst case I could always contact the site using a different IP.
 

Harunobu

Chumono
Messages
694
Reaction score
764
Location
Netherlands
USDA Zone
7b
This is the same problem many of us have been having for months. I just posted that this problem still exists. Yes, you as admin wouldn't be immune to it. You get banned for 1 hour because your attempt to post created internal server errors 5 times in a row. And your hosting probably thinks this might potentially be a hacking attempt because generating internal service errors is bad. Next time, use something like Tor browser and you have access immediately. Just in case it is an important thingy. In fact, I am doing this on Tor browser right now because I just got timed out as well.

I have had this now maybe 10 times? It is caused be long posts. I don't know why. At first I thought it may be 'bad' keywords or images, but that doesn't seem to be the case.

Bit surprised to know now that it is your firewall blocking the IPs. I thought I posted about this and you seemed oblivious to it. Well well...
 

Cadillactaste

Neagari Gal
Messages
13,367
Reaction score
13,590
Location
NE Ohio: zone 5b (USA)
USDA Zone
5b
Welcome back!

Goes to show us...the ins and outs that you do we are unaware of. Thank you for doing all the behind scene things to keep this site running smoothly. I may not spend as much time on as I used to...but when I do. It is always appreciated. I cut my teeth here...I wouldn't be where I am today without your site, and those here who are so amazingly generous with their knowledge.
 

Bonsai Nut

Nuttier than your average Nut
Messages
9,199
Reaction score
16,839
Location
Charlotte area, North Carolina
USDA Zone
7B
I thought I posted about this and you seemed oblivious to it. Well well...

One person's "obliviousness" can be another person's "I can't replicate your error, am seeing nothing in the server logs to indicate a problem, and no one else is having the same issue".

You are responding to the symptom, and not the cause of the problem. The cause of the problem is - what is causing the internal server errors - not the fact that the server firewall blocks you for generating them. Sure you can use an anonymous browser to keep the firewall from blocking your IP... but that doesn't fix the issue.

You seem really upset that this free web site isn't up to your highest technical standards. Maybe I should make it more free, or work longer hours for you.
 
Last edited:

leatherback

Imperial Masterpiece
Messages
6,920
Reaction score
10,775
Location
Northern Germany
USDA Zone
7
Hahahahaha
I have had that happen to me. I did call websupport who did not find anything. And after half an hour I was let back in. Thats when it hit me..
 

bwaynef

Chumono
Messages
959
Reaction score
838
Location
Upstate SC
USDA Zone
8a
On my treatise on repotting, I had this happen to me. I'm not sure if there's a limit on the length of a post, but that's about the only thing I can think of that I did to trigger an internal server error/5xx.
 

Mikecheck123

Shohin
Messages
470
Reaction score
724
Location
Redwood City, CA
USDA Zone
10a
Well I had an interesting moment today when I inadvertently locked myself out of the site - including all access to the server :) I always enjoy these problems because I learn something along the way... and it may lead to solving some of the uncommon problems that people occasionally have with the site.

I was in the middle of posting a response to a post, and got tripped up in what I was posting, so I pasted my response into the clipboard and hit the browser refresh button (F5) a few times. The web page locked up (!) so I closed my browser window and tried to reload the site again - to no avail. So I tried to access my admin account, and couldn't. Then I tried to access the client account on the server, and couldn't. Suffice it to say I was completely unable to interact with the site - even though my hosting account showed the server was up, and I was having no trouble accessing other Internet sites.

Turns out that I had spammed my way into a temporary firewall block of my IP by pinging the server too many times in too short a span of time :) Kinda funny when you think about it. It is probably a pretty rare occurrence since this is the first time it has happened to me - and I am on the site a lot and am constantly refreshing the site and reloading things. If it happens again, I'll have to tweak the firewall settings. For a couple of minutes I thought the site was being hit with a denial of service attack by Russian bots because I could see all the firewall messages - and then I realized the IP it was blocking was mine :)
Has it become sentient?
 

coh

Imperial Masterpiece
Messages
5,503
Reaction score
6,107
Location
Rochester, NY
USDA Zone
6
There's been a few times I've encountered an error when posting but I don't think I ever got locked out of the site. I didn't pay much attention but I think it happened when I was trying to edit a post and then when I hit "submit" (or whatever the button is) I got a message of some kind telling me I had to wait. Then after waiting a few seconds it worked.

Is there a time requirement between posts, even if you go in to edit your own post? Like maybe 5 or 10 seconds between posts? If so, I could imagine someone clicking a bunch of times and then possibly getting locked out for multiple server errors.

Just tried it with this post though (went back and edited within a couple of seconds) and didn't get the error. I'll have to pay more attention when it happens in the future.
 

Harunobu

Chumono
Messages
694
Reaction score
764
Location
Netherlands
USDA Zone
7b
Not sure why you are responding a bit agitated. I informed you of the issue a long time ago. And I did my best to nail down what it was. I am sorry you didn't believe me.

It is not about something being free or not. It is about offering help, and it being refused. Oh, and as far as me 'responding to the symptom', I was not. If it was just me being blocked, it wouldn't be a problem to anyone except me. Except that is not the case. Something about the forum is creating the error, for everyone. The timeouts is just how we (or better I) found out.

Not saying it is an easy problem to solve, whatever it is. I am sorry you tried to fix it and it didn't work. But if I read your OP correctly, you only figured out what was happening yesterday.
 
Last edited:

Bonsai Nut

Nuttier than your average Nut
Messages
9,199
Reaction score
16,839
Location
Charlotte area, North Carolina
USDA Zone
7B
Hahahahaha
I have had that happen to me. I did call websupport who did not find anything. And after half an hour I was let back in. Thats when it hit me..

Now that I have had it happen to me, and saw the browser error message, I have an inkling what may be going on. I don't think it is related (directly) to site, or to the server... But I first have to confirm the problem and then figure out how to fix something that may not be in my direct control.
 

Bonsai Nut

Nuttier than your average Nut
Messages
9,199
Reaction score
16,839
Location
Charlotte area, North Carolina
USDA Zone
7B
Hahahahaha
I have had that happen to me. I did call websupport who did not find anything. And after half an hour I was let back in. Thats when it hit me..

Can you try to trigger it again? I am trying some things but I have not been able to replicate the problem I had yesterday.
 

leatherback

Imperial Masterpiece
Messages
6,920
Reaction score
10,775
Location
Northern Germany
USDA Zone
7
Something about the forum is creating the error, for everyone.
Sorry, but in the somewhat 7 years I am here, and 5K posts and reading 10K @sorce messages I have not been locked out of the site. I would venture it is something YOU do, and not the site per se.
 

Similar threads

Top